Why are all my mailing ports (25, 465, and 587) timing out on my Linode servers?

Linode is now blocking SMTP traffic by default. If you need to use SMTP from your Linodes you will need to contact Linode and ask them to enable SMTP for specific servers. There is also a Linode community page about the issue.