How do I fix an "Deployment failed: Unable to install package(s)" error?

The most common reason for this error is that the version of one or more components specified in your manifest.yml and/or Docker file conflicts with other components - particularly with the version of the underlying operating system (Ubuntu).

If you are trying to upgrade an existing application - particularly one that had been running for 12 months or longer - be sure to check that you have not locked the version(s) of any packages via the Manifest or the Docker files. If you’re unsure about which version is correct, you should generally remove the line that specifies package version, as this will alllow Cloud 66 to install the latest supported versions of all the packages which reduces the chances of conflicts significantly.