Redis provisioning issue

Any time I try to provision a stack that contains redis I hit the error below. If I try to re-deploy after this failure it appears to work but the redis instance is not started.

I notice that rails-4.2 is getting pulled in despite it only being released today, could that be the issue?

Deployment failed due to Failed command: sudo bluepill load /etc/bluepill/autoload/cloud66_redis.pill. Error output: /usr/local/lib/ruby/gems/2.1.0/gems/activesupport-4.2.0/lib/active_support/number_helper.rb:3:in `': uninitialized constant ActiveSupport::Autoload (NameError) from /usr/local/lib/ruby/gems/2.1.0/gems/activesupport-4.2.0/lib/active_support/number_helper.rb:2:in `' from /usr/local/lib/ruby/gems/2.1.0/gems/activesupport-4.2.0/lib/active_support/number_helper.rb:1:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/gems/2.1.0/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric/conversions.rb:2:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/gems/2.1.0/gems/activesupport-4.2.0/lib/active_support/core_ext/numeric.rb:3:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/gems/2.1.0/gems/cloud66-bluepill-0.0.63/lib/bluepill.rb:14:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/site_ruby/2.1.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/gems/2.1.0/gems/cloud66-bluepill-0.0.63/bin/bluepill:3:in `<top (required)>' from /usr/local/bin/bluepill:23:in `load' from /usr/local/bin/bluepill:23:in `
'

Hi Kevin, yes that is likely the issue. I haven’t seen this problem before - please let us know if you’re still experiencing this.

I’m having this issue right now but it is related to my web server. I can’t deploy and my entire app is down.

Deployment failed: Failed to configure custom web server due to Failed command: sudo bluepill load /etc/bluepill/autoload/cloud66_web_server.pill. Error output: /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-3.0.20/lib/active_support/values/time_zone.rb:272: warning: circular argument reference - now /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-4.2.1/lib/active_support/number_helper.rb:3:in <module:NumberHelper>': uninitialized constant ActiveSupport::Autoload (NameError) from /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-4.2.1/lib/active_support/number_helper.rb:2:in ' from /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-4.2.1/lib/active_support/number_helper.rb:1:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require' from /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-4.2.1/lib/active_support/core_ext/numeric/conversions.rb:2:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require' from /usr/local/lib/ruby/gems/2.2.0/gems/activesupport-4.2.1/lib/active_support/core_ext/numeric.rb:3:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:69:in `require' from /usr/local/lib/ruby/gems/2.2.0/gems/cloud66-bluepill-0.0.64/lib/bluepill.rb:14:in `<top (required)>' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require' from /usr/local/lib/ruby/site_ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require'

All I did was restart my server that was working perfectly before the reboot.

Hi Brandon,

Sorry to hear you had this issue. Had you changed anything in your Gemfile/Gemfile.lock files between it working and then not working? I suspect this may have been a version conflict due to an upgrade, either in one of those files, or if an apt package was upgrade during the server restart. Had you received a restart notification for this server prior to restarting it?

Philip

There was a message saying 27 packages needed to be upgraded yes. I did not change my app in any way, I just restarted the server.

You must be logged in to answer this question