Package fails to install

I get this error:

There are problems and -y was used without –forced-yes

Unless the package installation changed (happens almost never), this will be the result of apt-get repository issue which can be either connectivity issue between the servers and apt-get repositories, or some issues with the repository itself. This mostly happens because there is an issue with the cloud provider repositories as they try to redirects all the apt-get requests to their repositories to reduce the usage of external bandwidth. Or it can be the result of some network connectivity issue.

So in order to find the issue, you can ssh to your server and run that command to see the result. If it succeeds you can again rebuild it, if not please follow the following steps:

  • If you are building a stack you’ll need to recreate the stack so your server will be built on a different hardware.

  • If you are scaling up, you’ll need to remove the server and scale up again to have your server built on a different hardware.

If you still get the same error, you need to contact your cloud provider and raise the issue.

You must be logged in to answer this question